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Introduction 

 

Version 4.0 software is targeted at all EVO, Constellation and Xynergi users. 

This documentation is a general overview about the new release. For users still on V3.1, there are 
sections listing the additional v3.2 features that are included in this release. 

Please note that some of the improvements are payable options. These include AVCi, SDS, 
and 3D audio. 
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New Features 

 

Version 4.0 

Mouse Editing and the Single Screen Interface 

Mouse Editing has been updated significantly. This is targeted at a number of market initiatives: 

1. It will provide a choice of working styles for all users. 

2. It will allow Fairlight to offer systems without controllers 

3. Current Fairlight owners will be able to employ editors without Xynergi experience. 

In addition, the Edit Screen has a new “Solo” skin providing a great deal of mixing functionality, with 
basic monitoring. This will enable compact single-screen workspaces for projects using no more than 
4 sub-buses. The user can optionally display bus meters, Pyxis track video, or Audiobase as needed. 

Clip Editing 

For mouse editing, we use the 7-point editing model made popular in some other products. When 
tracks are tall enough, each clip displays 7 points when the mouse hovers over it. The points can be 
dragged with the mouse to change head and tail trim points, fade points, fade curve shapes, and clip 
level. Note that clips need not be touching the cursor to make these edits, and the transport can be in 
play at the time. 

 

An editing toolbar is also provided, incorporating often-used commands like cut, paste, copy, delete, 
trim, fade, split, level, clip EQ, rename, marks, jumps, Audiobase and Clip Search. 

On-Screen Transport 

Transport Controls are built into the Status Bar. These include a loop control and a Jog button, which 
toggles mouse-based scrub, using right-click and drag. 

Edit Toolbar 

Instant access to a range of edit commands, irrespective of current mode. 
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Track-based Mix Controls 

Each track can show an extra row of mix controls when tall enough. These include: 

 Fader and Pan indicators – click inside the numeric field and drag up and down to change the 
value. 

 Auto button – toggles channel in and out of write/trim/preview (active when Mix is on) 

 Curve selector – allows local selection of fader, mute or pan curve on track (active when Mix 
is on) 

 

Automation Section 

The Edit Screen now shows a small automation box, where Mix can be turned on, and Fader, Mute 
and Pan enabled for writing. Touch controls are also available. 

Monitor Section 

A monitor section offers level control with Mute and Dim. 

 

Right Side Panel choices 

The right side of the Edit Screen has new panel choices: 

1. Pyxis – shows video screen and locators 

2. Mix Panel – shows a resizable mixer with Bus Masters above 

3. Pyxis with Mix Panel – shows video screen above and channel strips below. 

 

 

 



Software Release Information  NEW FEATURES  December 18, 2012 

DREAM II Version 4.0 Page 6 
 

4. Audiobase – shows search results, with or without video above 

Smart Pane Removable 

The Smart Pane has a new option: none. This is designed for use on small screens, chiefly for Native 
Solo products. 

Range Setting 

The Range panel now allows mouse-based setting of From and To point, as well as range on/off 
toggling. 

New menu option 'Setup -> Oscillator' which toggles the Oscillator on and off. 

Multi-Client ASIO Bridge - PT and Nuendo Control 

Available to EVO systems only. 

The ASIO Bridge provides hosting for other audio products e.g. ProTools and Nuendo. It makes the 
CC-1 look like a sound card usable by these other products. 

The result is that Dream II can run concurrently with PT or Nuendo – and the outputs from these 
products can be patched through to Dream channels for further processing and mixing. 

An option for EVO users will be to purchase a low-cost ProTools version such as ProTools10, and use 
it to immediately open clients’ PT sessions into the Dream environment. In this situation Dream can 
provide any of video, 9-pin, external sync, extra audio channels, EQ, Dynamics and plug-ins, 3D 
panning, mixing, monitoring and more and MIDI Timecode can be used internally, in either direction, 
to synchronize the transports. 

As part of this feature, MTC can now be routed internally using virtual MIDI ports like LoopBe30. This 
is configured by selecting a Machine to be MTC Chase and clicking the config button. 

The SX Device Port or SX MIDI In can also be selected. 

 

Dynamics Improvements 

Dynamic Max Linking now allows Multi-Element buses and Link Groups to retain correct imaging under 
dynamics. 

This is achieved by using the loudest element, at any moment, as the input to the gain calculation 
stage, and applying the same gain reduction to all elements. 

Compressor Side-Chain patching has now been added to the Patch I/O page. This allows any signal 
path to become the “key” for compressing any other signal path. A total of 48 side chains may be 
created within a project at any time. 

The Hold function is now operating correctly, which allows much faster Attack times to be used 
without hunting. 
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Clip Bins and ClipStores 

Every project now has a "Clip Bin". This is a place to store clips not being used at the moment. They 
are copied directly to the Project Bin using Edit->Copy Clips to Bin. This will target the currently 
selected clip(s). If a Range is present, only wholly included clips will be copied. 

To access them, use the Clip Search dialog, either from the View menu or by pressing GoTo->Clip in 
Xynergi. 

In the Clip Search dialog there is a checkbox for Bins. When this is checked the dialog shows all the 
clips in the Bin, which can be auditioned, previewed and pasted in the normal way. Note: the Bin can 
only be seen by the project from which it was created. 

ClipStores work in a similar way, but can be located anywhere on your network, and are accessible to 
all users. ClipStores can be created at any time using File-> New ClipStore.  
They have the extension .CLIPS. 

To open a ClipStore, use File->Open ClipStore, and browse to the file you want. The project 
remembers which ClipStores have been used recently - these can be accessed via the File Menu also. 
Multiple ClipStores can be opened at the same time, and by multiple users. 

To place clips in a ClipStore, select them (inclusive range optional) then use the Publish Clips to 
Clipstore command on the File Menu. While this dialog is open, you can choose which of the open 
ClipStores to target. If you have selected multiple clips, you can save them as a Grouped Clip, and 
give them a name. If your ClipStore is to be shared on a network, the Localize Media checkbox should 
be used, so that the media is placed in the appropriate folder under the ClipStore file. 

Multiple users can publish at almost the same time to the same ClipStore. Because the clip metadata 
is very small, the ClipStore is only opened for Write for a short time, making clashes between users 
relatively unlikely. If a clash occurs, the later publish command will be held off until the earlier one is 
finished, which will hang the late-publishing system for a short period. 

Local Search, Preview and Audition 

Many users requested “In-Project Audiobase” which they found extremely useful in earlier products.  

In response, we have added Paste, Audition and Preview Softkeys to the Clip Search window (access 
via View menu or GoTo Clip Name). 

This gives excellent string search facilities within the project, plus Audiobase’s ability with preview and 
audition. It also allows instant access to the folder containing any audio used in the project. 

The ClipSearch Window can be extended to all open libraries as well, and its preview and audition 
functions used in the same way. 

Clip Search now remembers its last view settings. 

Preview from Windows Explorer 

File Menu -> Import -> Audio File(s).  This allows the user to open up a custom Explorer window 
allowing Preview, Auto-Preview (click and hear) and Audition of individual audio files on the Windows 
file path.  The user can then either drag/drop multiple files directly to the timeline, select Paste to 
place the selected media at the playhead, or select Import to place the media at the playhead and exit 
the dialog. This is only available in Windows 7. 
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AudioBase 

Improved Search Times 

Significantly sped up the time it takes to get results from Audiobase by talking directly to the SQL 
database. Typically we are seeing up to a 7-fold speed increase in search times. Publishing is also 
much faster. 

To enable this you must specify the SQL database type of your Audiobase server to either 'Microsoft 
SQL' or 'MYSQL'. This is done in 'Setup -> General Preferences -> Audiobase'. You specify the server's 
name and the type of connection to be made to the server, where 'HTTP' is the old method.   

When set to 'Microsoft SQL' or 'MYSQL' you now also get instant search results when you type at least 
three characters, allowing you to home in your search quicker. This gives you up to the first 100 
matches as you type. Pressing search will get the rest of the results. 

For MYSQL database users you need to be using the latest Audiobase installer 'SetupAB3-0064-3.5.6'.  
After installing it you need to run the SQL script 'AB3_MYSQL_Update_user.sql'. This updated the SQL 
user we use so that it can be used remotely. Microsoft SQL Audiobase setups do not need to be 
upgraded. 

The Audiobase smart pane now has radio buttons to choose between doing a global search or field 
search and disables controls that are not used during the particular search type. 

Split Audiobase Database/Media Server 

It is now possible to specify a separate media server for Audiobase, in case the projects from which 
the clips were published are accessing a shared media server. 

Please contact Fairlight support for information on how this is set up. 
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General Improvements 

After Audiobase search results are returned you can now also use the Enter key to add the selected 
item to the timeline. Double clicking on an item still works also. 

The Audition button on the Audiobase smart pane now lights up when in Audition mode. You can also 
now press it to exit Audition. 

VCA Extension 

The number of VCA groups has been increased to 32. VCA control has been extended to handle all 
pan control parameters; including 3D ones (Up-Down and Tilt). 

ADR Export 

Added ADR Export to CSV to the ADR List. 

Track based beeps can be disabled via a checkbox in the ADR Preferences dialog. "Patchable" beeps 
can be disabled by not patching them anywhere. 

Mixer Screen Improvements – FMC2 

The Bus Master meters and faders have been merged, in the upper part of the Mixer screen. This 
consumes less space and is easier to follow.  

The bus sections size automatically when necessary, so a much larger number of buses can be 
displayed. It is also now possible to set a scale for the digital peak meters, as well as the threshold for 
the  yellow and red segments.  These are configurable in the Setup->General Preferences Meter tab. 

Channel strips now include Auto buttons. 

Mixer Scrolling 

Previously the new Mixer screen could only be scrolled using the mouse. Now there are two 
alternatives: 

Holding down the ctrl button causes the Bank Switches to become Mixer Scroll buttons. Each press 
moves the display by 24 channels. 

The mixer can be set to automatically scroll to the current mix channel. To do this, go to the Call 
Menu in the Setup Megamode, and select Scroll Mixer. 

Customisable (3D) Bus Formats 

A new panel has been added to the Fairlight Setup Utility, where users can create new bus formats, 
based on the position and panning behavior of speakers. 
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The setup space includes three dimensions, and the dialog displays an interactive room diagram 
showing the positions of all speakers, updating in real time as values are changed. 

Copying and editing existing formats is easy, but the “factory” formats are locked to prevent loss of 
performance on previous projects. 

The list of formats can be ordered so that the most useful ones appear first in the Bus Format mode 
on Xynergi’s Pad. A “more” button allows access to more than the 8 formats currently available. 

All legacy projects are fully supported, even if the use Bus Formats no longer displayed in Xynergi. 

Monitor Speaker sets and Link Groups can be chosen to conform to any defined Bus Format within the 
system. 

Copy Project Segment 

New command in the Edit Menu, copies everything from a range to the cursor position. It is a 2 step 
operation - the first copies the clips and all automation in a range into the clipboard, which can then 
be manually pasted at the playhead.  This separation allows you to copy a whole project segment 
from the import workspace and paste it into the main workspace.  The copy is still selection 
independent. 

The audio from all tracks will be copied (whether selected or not), plus the automation from all signal 
paths, all parameters (whether enabled or not). 

In addition, the Automation Follows Edit functionality (Target Both) has been extended to be purely 
range based when a range is active.  This allows editing of the automation on the timeline where 
there are no audio clips.  This also allows editing of the automation on the new mixer tracks.   This 
functionality is also available within the import project, and so it is now possible to copy an entire 
project segment using only Target Both. 

Normalize Audio 

New command in the Clip Level mode and the Edit Menu, uses Clip Level to set the loudest point in 
each clip to full scale. Can be used on single clips or ranges. 

Replace Audio 

Destructively replace audio in compatible clips, faster than real time. See Process->Replace Audio on 
Selected Tape Mode Clips 

P2 Replace Mode 

This allows the audio within P2 MXF files to be replaced. P2 multi-clips are now represented as a 
single timeline audio clip (instead of multiple timeline audio clips). Tape replace mode works correctly 
with P2 multi-clips-as-single-timeline-clip. Beware: previous projects which contain P2 multi-clips 
(created with beta software) may now not load correctly. 

Further P2 clip faster than real time overwrite enhancements. Multiple P2 clips can now be     
overwritten using a range. To keep audio data in synch on the timeline, select a source range on the 
timeline (using range), copy, then maintain the same range, and select the tracks containing the P2 
clips to be overwritten. 

The use: Process->Replace Audio on Selected Tape Mode Clips  

You can also use the new feature to overwrite a small section of a P2 clip. Just remember to keep 
your source range and destination range the same to keep it in sync. The source range can contain 
edits. 
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AAC Export 

AAC is a new audio codec choice when creating QuickTime video exports. It is listed as 'MPEG 4 Low 
Complexity AAC' in the QuickTime audio export options. 

Note: This version will reset your last chosen QuickTime audio export options as the data is now 
stored in a new format. 

Video Cache 

Video Cache Seeking algorithm can be set in: 

Setup->General Preferences->Playback->Video Cache. 

Choices are "Standard" and "No seek". 

Choose No Seek when playing back media files which are difficult and slow to seek, for example: long 
gop mpeg, wmv, H264. This will improve playback reliability (at the expense of backwards jog 
capability). 

Miscellaneous 

Solo Follow feature for Library projects. In QDC Solo Follow was automatic when browsing Library 
projects - this is now an option in the Solo menu (hold down Xynergi Solo button). 

Define Project Start Time. 

SX-48 sync status LED on Sync pane. Also User warning when SX-48 Sync lost. 

Added Registry setting "Audio Engine->OverrideTrackCount" to change track count below currently 
licensed count. For example, set OverrideTrackCount to 96 if you want to run Dream II with 96 tracks 
and 48 lives (144 Channels). The actual registry key is 
HKEY_CURRENT_USER\Software\FairlightAU\Dream II\Audio Engine 

Comprehensive Mpeg2 Export. 

BLUE + ENTER localizes currently selected clips. 

Mainconcept broadcast AVCi decoder 

Added the registry option 'Editor -> surroundGroupTracksWithRed'. This re-enables an old display 
feature where group tracks are surrounded by a red border. 

In the menu option 'View -> Displayed Clip Information' added the option 'Gain Icon'. When enabled 
this will display a gain icon in the bottom left corner of the clip when a clip has gain applied to it. 

Pyxis G2 now has the old Pyxis NLV style 'Locate to' dialog which can be used via a touch screen to 
enter timecode. 

In the menu items 'Clip -> Set Clip Colour' and 'Tracks -> Set Clip Colour' there is a new menu option 
'Custom Colour'. Allowing you to choose your own custom colour for clips. 

Pressing the keyboard letter 'r' now turns the range on and off. 

Added a new option to "Setup General Preferences -> Options -> Display Clip times in Range Display".  
When there is no range the range display will display the start time, end time and duration for the 
first selected clip. 

Added a new menu item "Help -> Send Message to Fairlight". This opens a dialog for reporting bugs 
and feature suggestions to Fairlight via the BUGtrack system. This feature requires an internet 
connection.  
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Version 3.2 

SDS 

The Dream II Sound Design Sampler (SDS) is intended as a tool for use in audio production and post 
production.  SDS functions include fast access to sounds stored in AudioBase or clips on the Project 
timeline, PAD based manipulation of ADSR, level, key assignment, etc. and integration with Project 
saving and loading. It is subject to license agreement. 

Access to SDS is via the new SDS button in the Editor Megamode. It is described in detail in the V3.2 
and V3.5 User Manuals. 

File Import/Export/Playback 

You can now choose the number of channels for export in any of the export video pages (within 
allowable min and max bounds). You can choose the first <n> tracks, or select tracks using track 
selection keys. 

You can now choose to extract audio from quicktimes, use native audio, ignore audio, or ask. See: 
Setup>General Preferences>Options. 

DPX file sequence playback (preliminary). 

Dream II now reads GXFPak XML files (CLIP0001.XML), and stitches all the associated files (audio and 
video MXF) together. To make this work, drag a folder onto the timeline containing the XML file.  

Dream II now reads P2 XML files (e.g: 0005YC.XML), and stitches all the associated files (audio and 
video MXF) together. To make this work, drag a folder onto the timeline containing the XML file.  

New parameters when importing edl formats (OMF, AAF, FCP) Timecode offset can now be absolute 
(start at) or relative (offset by) "Import track names" specifies whether to import the name of the 
track(s) or not. 

Embedded SDI. 

Track remapping and naming, when importing OMF, AES31, AAF, FCPXML. 

AAF now has Unicode support 

Dream now recognizes .mpeg extension 

Editing 

Paste Selected clips from Clip View window. Clips can also be dragged and dropped from clip view 
window. Multiple clips can be pasted or dragged, Stereo and multi-channel clips are handled. 

Gating can now optionally be performed using profiles (faster), or audio samples (more accurate). 

A new feature has been added to marks. You can now make a mark a 'Line Marker' in the 'Marks 
Dialog'. When a marker is a 'Line Marker' a line is drawn down the timeline at the point of the mark. 

Now when you drag media onto the timeline it follows the same snapping rules as dragging clips 
around on the timeline with the mouse. This makes it easy to drag some media onto the timeline and 
have it begin at the playhead or in line with some other clip. 

Previously Audiobase displayed a sound’s duration only in seconds. This has been improved so that 
the duration is now formatted to include minutes and hours if the duration is long enough, instead of 
a large number in seconds. 

Profiles are generated whilst recording, to greatly reduce the time that is required for profiles to 
appear after recording. Can be switched off if required using the DEBUG switch: "record", "generate 
profiles during record" (on by default). 
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Profiles are now generated for selected clips first, before moving onto the rest of the clips. 

Missing MFX/QDC feature: Ctrl+Arm key disarms all tracks.  

There is now a new option in the Seed name dialog to include the track name as part of the seed 
name. The track name is then appended to the head of the seed name for recorded clips. 

You can now specify if marks create undo points and are undone by undos. There is a new option in 
'Setup > General Preferences > Projects' in the 'Undo/Redo Options' section called 'Marks are 
undoable'. By default this is enabled. 

Machine Control 

Creep (tug) velocity can now be configured in the vtr config dialogs, to accommodate VTRs which 
overshoot trying to jog to a specific frame. The default value is 0.1 speed. If the VTR overshoots, try a 
smaller value, like 0.05 down to 0.01 

9pin control "nonlinear" tracking mode. Typically used when connecting a PyxisNLV to a DreamII. 
Experimental.  

User Interface 

A new section has been added to the status bar to display which TUI edit menu is currently enabled, 
or which Xynergi megamode the Xynergi is in if not in an edit mode. 

Added the keyboard short cut 'Ctrl Shift ~' to display/hide the video scroller for the second video track.  

For Xynergi the track bank status bar display has never displayed anything as this does not apply to it. 
Instead for Xynergi this area now displays if you are in 'Multi’ mode. It is displayed with a red 
background.  

The range display on the editor screen now indicates if the range is currently on or off. It does this by 
greying out the range times when there is no range. 

System Resources 

Added Registry setting "Audio Engine>OverrideTrackCount" to change track count below currently 
licensed count. For example, set OverrideTrackCount to 96 if you want to run Dream II with 96 tracks 
and 48 lives (144 Channels) 

Automation 

New Import/Merge Mix Functionality. The Import Menu has been enhanced to allow automation to be 
selected and previewed using automation curves from within the Library project. This automation can 
be copied and pasted using either Target Both, or an "Import Mix" Button. Whilst the former allows 
simple clip automation merging, the latter uses the active mix masks and automation parameter 
enables to allow filtering of the copied mix data. This is exactly the same as the previously introduced 
"Copy Mix" functionality. 

Number of Tracks 

The new project dialog now uses a combo to display the number of tracks for the new project. For 
Dream II projects you can also specify a custom amount of tracks for the project to contain, instead 
of having to use 'Set Audio Track Count' to adjust the amount. For MT and MFX3 compatible projects 
the custom number is ignored as the QDC and MFX3 had set track counts. 

The number of SDI embedded audio channels can be configured by command line parameter (for 
diagnostics and testing). 



Software Release Information  IMPROVEMENTS  December 18, 2012 

DREAM II Version 4.0 Page 14 
 

Improvements 

Version 4.0 

The edit menu has been split into two menus 'Edit' and 'Clip' as it was getting too long.  This also 
leaves more room for new menu items in each of these menu's in the future. 

AVI and WMV files can now play in stereo (3D). 

Rendering algorithm for DPX 10 bit (linear, not log) files made more efficient. 

GUI support for SX12 and SX8. 

Increased the width of the QuickTime Audio Extraction DropDown so that all the text is visible. 

Compatibility issues addressed with AVCi MXF files exported by Dream II. 

Compatibility issues addressed with MXF files created by Automatic Duck, exporter for FCP. 

DNxHD MXF compatibility issues resolved. 

In Setup -> General Preferences -> Audiobase' you now only need to specify the server’s name 
instead of the full http address, making it easier to add an Audiobase server. 

New controls and parameters to allow Panasonic D5 machines to synch reliably in 23.98 fps. For a 
Panasonic D5, set Servo Lock Threshold to 12 (or more). Set Resync Delay to 4.0 seconds (or more). 

MXF audio files encoded with AES3 audio encoding can now be used as tape mode clips. 

The location for profile files for MT projects has been modified, so that the files are distributed more 
evenly into subfolders. 

Fixed problem reading some EDLs resolved. The problem occurred with EDLs that did not contain 
carriage returns. 

Previously, dragging a file onto the timeline could cause the file to be opened again, even if it was 
already open, leading to many file handles being left open. 

When previewing sounds with Audiobase it now closes the files once you have stopped previewing the 
file.  Previously each file that was being previewed was being left open to the project was closed. 

 (819326) 9pin fix for protools status bit inconsistency. 

Now constrains the Audiobase Audition path to within the Audiobase server's media folder. 

The Audiobase/Pyxis Window now remembers its width between sessions. 

The cancel button on the "Scanning for Media" progress dialog is now checked more often making it 
more responsive. 

Mpeg Export: Export Mpeg1 or Mpeg2. 

Added SDS manual Save/Load. 

The playhead now longer moves and the timeline no longer zooms when an OMF file is imported. 
Similar behavior with other import formats as well. 

Added Windows 7 64-bit USB drivers for the legacy "Station" Controller. 

The resolution of a quicktime video file is now derived from the dimensions of the media, in 
preference to the dimensions of the video track, in the rare situations where these values don't 
actually match. 

Fix for the FMC2 strips. Previously a Live strip was only displayed if it had an input, now also if it has 
an insert return. 
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Blue + reset to default functionality added to EVO ILP switches. 

Selection of Maintain Aspect Ratio is now remembered between successive video imports. 

Version 3.2 

SX48 sync status LED on Sync pane. Also User Warning when SX48 Sync lost. 

 (#818760) Creep (tug) velocity feature, and machine control tweaked. 

(FMC2): The pan graph has been made larger and the boom level has been moved below pan graph 
to make more room for the pan graph.  

(On Windows 7) If you turn off your PC while Dream II is running with a project open. If autosave is 
turned on it will automatically save your project. If autosave is turned off Dream II will save your 
project with the name 'Shutdown.DR2' in the same directory as your current project. 

[#818699part1]. Gating is now performed with a minimum amount of accuracy. Previously gating 
always used the same accuracy as the profile drawing. This could lead to inaccurate results, when the 
timeline was zoomed out.  

A new parameter is available in General Preferences->Options called 'Clip EQ Algorithm'. Choices are 
'Fast' and 'High Quality'. Audio Clips with significant bottom end will sound better with clip EQ 
switched to 'High Quality'. 

Added Further PyxisG2 Menu access to mix functions. 

Addition of several new Xynergi layout mechanisms to allow override of the PAD buttons. 

After creating a group clip it now gets highlighted red, as the clips that made up this group clip were 
selected previously. 

Audio inside WMV files is now extracted much quicker than previously. 

DPX parameter editor (preliminary WIP) 

Dream II now reads the license file directly rather than waiting for FMC to send the license info. 

Export>Audio now remembers the last settings (such as the destination folder, etc.) correctly, after 
you bounce and render audio to track. 

Exported clips now contain embedded track information (in iXML format). 

Fixed a couple of second freeze that would occur with Dream II when loading MT projects.  

Further SDS fixes.  

GUI support for SX12 and SX8. 

ILP2 Mic Pre control improvements. 

Improved handling of audio for AVI files that contain PCM uncompressed audio samples (any number 
of tracks). These files can now be dropped onto the timeline and the audio is accessible straight away, 
without any rendering/extraction required. 

Includes CC1 Core 393. Which adds some of the following new features: Support for the SX12. 
Recording monitoring level for 16 bit audio. 

Increased the speed of returning large amounts of search results from Audiobase by a factor of 
around 3 times. This also requires an update to a new version of the Audiobase Server to take effect. 
Contact Fairlight Tech Support to obtain an update to version 3.5.4 of AudioBase 3. 
joe@fairlightau.com or johnd@fairlightau.com  

Increased the width of the QuickTime Audio Extraction DropDown so that all the text is visible. 

MIDI tracks now have SOLO buttons. 
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MXF issues with Ardendo AAF Tools generated DNxHD video files addressed. 

MXF issues with Ardendo AAF Tools generated DV video files addressed. 

MXF issues with Ardendo AAF Tools generated audio and imx mpeg video files addressed. 

MXF issues with EVS resolved. 

MXF issues with Harris Corporation Nexio files. 

Now when using a startup template project, the new project dialog is displayed so that you can name 
the project, and set the comment in the one place. This also gives you the option of having the 
project created in a subdirectory. This makes the template project naming more consistent with 
creating a new project. Also new project options like frame rate, display rate are grayed out informing 
the user of the current project settings from the template project. 

On Windows 7 64bit, the video cache is no longer reduced from 48 frames to 24 frames when in HD 
mode. 

Profile generation is now performed significantly faster (when the transport is stopped). 

Project switching from main project to library is now faster (especially when the media is coming from 
a network) 

PyxisMT UI Cleanup. 

Significantly sped up the sorting of the Audiobase columns when there was a lot of results returned. 

Support for Load of plugins remotely (e.g. via Intellipad macros). 

SX12 9pin port wiring is set to master or slave according to machine control mode.  

The menu 'Group Clips' is now disabled when there is no range, as it is a range based operation. 

The New Project dialog no longer stops the transport when it appears. It only stops the transport if 
the 'OK' button is pressed. Also the TUI now still works if the New Project dialog is brought up via the 
TUI, making it consistent with bring the New Project dialog up via the GUI menu. 

The next Audiobase search after a large search would take a long time as it was taking a while for all 
the items to be removed from the list. Now it does not take a long time for the Audiobase results list 
to be cleared.  

The selection of a video storage device is now exactly the same as audio, and will choose the same 
device as the project provided (a) the device is online (b) the device is specified for video or both (c) 
the device has enough space. 

The track bank display in the status bar now displays when you are in the first track bank. Previously 
it only displayed text when a higher track bank. NOTE: This is for non Xynergi users only.  

The video window no longer flickers briefly to black when an undo/redo occurs. Note: This issue only 
affected the computer monitor not Decklink output. 

There is now a check box in the 'Discard Unused Media' message box allowing you to turn off 
checking if any of the backup projects are referencing the media. This is useful if you are discarding 
media for a project that has been completed previously and you are cleaning up the project for 
backup. 

When the Dream II editor screen was configured to not run on the primary monitor it would have a 
border around it. This border has now been removed. 

You now have a lot more audio export formats within QuickTime you can choose when you are 
exporting a QuickTime video. 

Addition of Render Handles in the Audio Plugin General Preferences. This allows the retention of up to 
100 frames clip handles when rendered with a plugin. 
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Xynergi 

Added "jog review" option to Setup Megamode. This allows the PlayJog button to be an unambiguous 
Jog key. 

Added "save proj" button to Editor and Record megamodes 

Set source is now independent for Tracks and Lives. It also has new layouts for patching Live Direct 
outputs and MADI inputs, and handles Link Groups by patching successive inputs to the members. 

QuickLink feature – select a series of tracks, then hold down Blue and press one of the track buttons. 
The tracks will become a Link Group. 

New shortcuts for Bus Selection using the Numpad buttons: 

 Shift + 0 -> selects Main bus 

 Shift + 1 -> selects Sub 1 (and so on up to Sub 8) 

 Ctrl + 1 -> selects Aux 1 (and so on up to Aux 9) 

 Ctrl + Minus -> selects Aux 10 

 Ctrl + Plus -> selects Aux 11 

New method for selection of “Aux Contributors” 

 Ctrl + Shift + 1 -> selects tracks and lives sending level to Aux 1 (and so on up to Aux 9) 

 Ctrl + Shift + Minus -> selects tracks and lives sending level to Aux 10 

 Ctrl + Shift + Plus -> selects tracks and lives sending level to Aux 11 

 



Software Release Information  BUG FIXES  December 18, 2012 

DREAM II Version 4.0 Page 18 
 

Bug Fixes 

Fixed the embedded timestamp within exported MXF files. Previously the timestamp was not read 
correctly by Ardome systems. 

Fixed DMA overrun that could cause incorrect playback during editing of Clip Level or Eq. Also, Clip 
Level Cancel now correctly refreshes the playback buffers with the old level.  

(#818954), DNxHD 120 interlaced files was broken. Broken in v3.2.0b32. 

("Ballooning fuf"). Previously audio embedded in .MT projects originated on a QDC or MFX system was 
erroneously extracted to FUF files when "Backup to Folder" was selected.  

"Render Video Clips to XXXX" functions now work on multiple video tracks. 

#818593, fixed a bug where illegal video playback advances could be entered into the combo box. 

#818680, previously recording @ 96khz, with rf64 wav file mode switched on, could prematurely drop 
out of record, with the error message: Maximum File length reached.  

#818915, MXF HD422 LongGOP Export was always result 16bit, when "native" was selected. 

(#818480) non local media icon could give false positive.  

(#818612 hopefully). Previously AVCI MXF files exported from Dream II were not compatible with 
Quantel.  

(#818612), previously AVCi MXF files exported from Dream II did not contain a pictureEssenceCoding 
value in sufficient detail.  

(#818704) Export>AudioFiles, Progress bar weirdness rectified. 

(#818733) Previously dropping a quicktime file onto a timeline with MIDI tracks, could have issues. 

(#818743) Previously adding a video track caused the transport to stop responding, if video pipeline 
was turned on. 

(#818743) Quicktime audio cache substantially improved. Previously, dropping a quicktime file that 
contained audio could cause the system to stop playing, and to refuse to go back into play, due to 
slowness accessing the quicktime audio (made worse when profiles were being generated). 

(#818749) Previously the decklink Output was not cleared on Close Project. 

(#818755) Rendering video to another codec (e.g. DV) would revert back when undo was used. 

(#818781) Hang when choosing Setup>General Preferences (decklink card PRO2 present). 

(#818830 &#818781). Decklink hang on Play + Setup > General Preferences. Refixed previous bug 
that somehow became unfixed. 

9pin machine control problems between Dream II and Pyxis NLV resolved. The problem caused delays 
and stalls when transitioning between REW/FF directly toPlay. The same issues sometimes appeared 
when controlling a Sony tape VTR. 

Allow a Console template load over an existing mix without grouping information being cleared from 
the mix. 

associated with embedded SDI. 

audio embedded into SDI In more stability improvements. 

audio embedded into SDI In stability improvements. 

audio embedded into SDI In (decklink card).  

Audio scroller media files could remain open after closing a project.  
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Bogus "variable frame rates" message removed for some Quicktime files. 

Dpx file sequence fix. 

Dream II can now read different flavours of AVCi on the same timeline. Previously different flavours of 
AVCi caused the AVCi decoder to stop working. 

Dream II now recognizes BMD Decklink drivers v8.0 and above. 

Fix a bug with jumping left when there was less than one sample difference between two clips, as it 
would only detect one of the clips. 

Fix for VCA Grouping offset when applying offset. 

Fix of issue with ILP2 + link grouped channels, whereby the blank RHS was still active. 

Fix of Plugin Config page issues introduced by the SDS. 

Fix potential cold start SX20 issue, introduced in previous build.  

Fix to Neve 4081 logic when loading a console template. 

Fixed a bug introduced in v3.2.0b64 which caused an exception to occur when the audio track count 
for a project was reduced. 

Fixed a bug where if you clicked the Takes button quickly the Takes smart pane and meters smart 
pane could get stuck on.  

Fixed a bug where performing an undo on a Slip Sync point operation was not refreshing the audio 
cache for the track that was affected. 

Fixed a bug where undo was not reloading the caches for tracks that had had an 'LR Stereo Swap' 
operation performed on them. 

Fixed a bug with group clips were making a copy of a group clip could affect the play back of the 
original copy.  

Fixed a bug with the highlighting of clips that ended less than 1 sample apart. 

Fixed a case where if Quicktime failed to flatten an exported video to make it 'Streaming compatible' 
you would end up with no exported video file. Now you are at least left with the intermediate 
Quicktime video file which has not been made streaming compatible. 

Fixed a crash that could occur when Auditioning a clip. For the crash to occur you had to have some 
explicitly selected clips on the timeline before you began the audition with at least one having an icon 
on the clip ie. the EQ icon. You also had to be in nonlayered view and have 'Show Actual Crossfases 
(Layer Display Off)' unticked. 

Fixed a crash that occurred when trying to search Audiobase on XP machines. Introduced in v3.2.0b33. 
This issue did not affect Windows 7 machines.  

Fixed a crash that would occur at startup when using a template project. Bug introduced in v3.2.0b9. 

Fixed a rare bug where the clipboard could be displayed offset from where it should be. It would 
paste in the correct spot. Previously it would take a restart of the system to fix this issue. 

Fixed a rare crash that could occur if you were using the FMC2 screen and you changed the value of 
'Mix On' or the current touch state. 

Fixed a rare crash that could occur when live automation was being displayed on the editor screen.  

Fixed an issue if you had an ILP2 screen or FMC2 screen displayed and the DirectX device was lost (by 
pressing CtrlAltdelete, or the Windows 7 UAC dialog was display), where the ILP2 screen or FMC2 
screen would freeze. 

Fixed an issue on Windows 7 with some graphics cards, where the smart panes were not displaying. 
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Fixed an issue were the wrong amount of video card memory was detected on Windows 7. 

Fixed an issue where column orders were no longer being saved in Windows 7. So columns in dialogs 
would always go back to their default positions each time Dream II started. 

Fixed an issue where corrupted graphics could appear on the FMC2/ILP2 screens if the DirectX device 
was lost (by pressing CtrlAltdelete, or the Windows 7 UAC dialog was display). 

Fixed an issue where Dream II would freeze while viewing the Permanent Log via the Help menu. 

Fixed an issue where the LED lights would not be displayed on the sync setup smart pane when the 
Dream II editor screen was not on the primary monitor. 

Fixed an issue with machines where there primary monitor was not number 1. This would cause FMC2 
to draw over the task bar. 

Fixed an issue with the 'LR Stereo Swap' where the audio caches were not getting updated also. So 
required a locate away and back again to hear the difference. 

Fixed an issued causing flash frames in compressed video playback (I frame mpeg, jpeg, Huffman). 
Bug introduced in v3.1 

Fixed by introduced in v3.2.0b3 which caused some pictures not to load anymore on fresh machines. 

Fixed for case where more than two audio scrollers could appear on the screen. 

Fixed New and SaveAs dialogs to limit MT project file names to 28 characters. MT file names must not 
exceed the 28character limit familiar to mfx and QDC users otherwise various features and may be 
jeopardized. When opening a project that already has a name that is too long, a warning message will 
advise that it should be renamed.  

Fixed so that nonfatal exceptions do not bring down Dream II. 

Fixed some problems saving an MT project when there are clips with lost or offline media.  

Fixed the Monitor panel setup rotary functions 

FMC2: Buss assign indicators were not indicating automation status or adhering to automation rules. 

FMC2: Fixed a bug where the FMC2 screen would scroll when some other change happened within the 
system when it should not. 

FMC2: Gate/Expander curves could be seen on the dynamics graphics for busses, these were old 
graphics from earlier channels.  

FMC2: The Sub and Aux buss strips incorrectly had a solo button on them which has now been 
removed.  

Further 9pin machine control Bidirectional tweaks. 

Further fix related to previous "flash frames in compressed video playback" (I frame mpeg, jpeg, 
Huffman). 

Further fixes and additions to the new Xynergi PAD layout mechanism. 

Further support for 10 bit DNxHd quicktime files. 

Generate DVCProHD (DV100) data at the correct frame rate. 

ILP2: Fixed an issue where Band 1 or 4 Q was not enabled in some states when it should have been. 

to Audiobase change made in v3.2.0b5 so that sorting works again with the duration. 

In 'Setup > General Preferences > Themes' the combo box to choose what monitor number FMC2 
should display on, was not taking into account machines that had gaps in their monitor numbers. 

issues associated with video capture, using the new PRO2 interface resolved. 
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Issues with Network Adapter interrogation. 

mainconcept v8.8 demo MPG2 codec enclosed (with watermark), as proof of concept.  

More 9pin machine control Bidirectional tweaks. 

More reliable fix for SX12 Video sync was sometimes lost after changing samplerate.  

Open/New/Close project sometimes failed to disarm tracks and stop transport. Introduced in v3.2.0b9.  

Possible fix for stuck transport keys.  

previously 16 track wave files would not generate a correct profile (on win XP systems) 

Previously importing multiple consecutive quicktime files in a row could induce incorrectly imported 
audio. The problem did not happen with drag and drop quicktimes. 

Previously opening a backed up copy of a .MT project could access the original media, not the backed 
up media. 

previously the timecode embedded into Quicktime mjpeg .mov files could be incorrect up to 1 frame 
in NTSC. 

problems associated with duplicate file names when backing up to folder. 

problems associated with slow import of embedded OMF files resolved. 

problems associated with using 'Localizing Video' multiple times resolved. previously, using 'Localizing 
Video' multiple times could leave a project with video clips that become offline. 

quicktime tweaks to allow a faulty mp4 file to play correctly. 

read timecode tracks in quicktime correctly if the timecode rate is different to the video rate. 

Recognize the 'ID3' tag found at the start of some MP3 files, most notably those encoded in Itunes, 
which caused these file to not be read by Dream II software. 

resolved a 9pin machine control problem with bidirectional switched on. 

Resolved a problem that would cause DNxHD36 MXF files to crash. 

Restored "Read only" volume functionality, which was broken in 3.1.0b9. 

Setting From/To Next or Previous Gap would crash application in certain conditions.  

Several improvements to bidirectional 9pin machine control. 

Several improvements to single screen operation. 

Several stability fixes to attempts at simultaneous loads (e.g. Load Project before Load Mix had 
completed). 

Some tweaks and additions to JogMix functionality. 

Stability issue fix associated with background localize/fuf stuff whilst playing. 

Support 10 bit DNxHd MXF files. 

SX12 Video sync was sometimes lost after changing sample rates.  

SX12 WCLK output control was broken. Also SX12 WCLK output is now disabled when WCLK sync is 
selected, as it should be.  

The beats lines on the track view were not being drawn after the origin time if the current display 
included the origin time. 

The Jogger Wheel no longer worked browsing AudioBase results, was broken in v3.2.0b46. 
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The video memory usage percentage has been removed from the performance monitor dialog, as it 
cannot be detected in Windows 7. 

Various SDS fixes, including reintroduction of automatic velocity mapping. 

Video scroller would get out of sync when changing frame rates. Previously needed to remove it and 
add it back again to fix.  

When assigning a new user name for the Sub or Aux busses the new name was not appearing 
straight away within the Bus meter display, on the top right hand side of the FMC2 screen. 

Xynergi layout fixes. 

Previously destructively over recording clips in replace mode that had been edited did not give correct 
results. 

Compatibility 

To enable 3D/dual stream video playback, you require (a) appropriate dongle (b) to turn the feature 
on and off in view menu.  

issues addressed with MXF files created by Automatic Duck, exporter for FCP. 

DNxHD MXF issues resolved. 

 


